Scheduled for June 08, 2024 at 4:00 PM – 4:47 PM
Completed
June 08, 2024 at 4:47 PMCompleted
June 08, 2024 at 4:47 PMThis maintenance has been completed and units are back online
In progress
June 08, 2024 at 4:00 PMIn progress
June 08, 2024 at 4:00 PMMaintenance is now in progress
Planned
June 08, 2024 at 4:00 PMPlanned
June 08, 2024 at 4:00 PMWe are planning for a scheduled maintenance to perform some system updates.