BreezeTech - Emergency CosmicGuard Dallas maintenance – Incident details

Emergency CosmicGuard Dallas maintenance

Resolved
Degraded performance
Started 5 days agoLasted 20 minutes

Affected

Data Centers

Degraded performance from 9:11 PM to 9:30 PM

DFW01 - Dallas TX

Degraded performance from 9:11 PM to 9:30 PM

Updates
  • Resolved
    Resolved

    Cosmic just advised the emergency maintenance has been completed at this time. We will monitor the network and advise if any issues surface. Apologies for the short notice!

  • Investigating
    Investigating

    We were just notified a few seconds ago that CosmicGuard is going to be performing emergency maintenance in Dallas. We apologize for the short notice on this, however we just received notification ourselves. We will advise once we receive the all clear. See the details below:
    -----------------------------------
    Hi everyone,

    In 5 minutes we'll need to perform an emergency procedure to our primary dallas router, traffic will likely drop for a few minutes.

    We apologize for the inconvenience this might bring to you.

    Affected

    Network Points of Presence → Dallas, Texas

    Scheduled for

    October 31, 2025 at 9:15 PM GMT - 9:30 PM GMT (15 minutes)

    -----------------------------------