BreezeHost - Billing Panel (my.breezehost.io) – Incident details

Billing Panel (my.breezehost.io)

Resolved
Major outage
Started 4 months agoLasted 41 minutes

Affected

Websites

Major outage from 2:03 PM to 2:44 PM

Billing Panel (my.breezehost.io)

Major outage from 2:03 PM to 2:44 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    We are aware that the billing panel is currently unreachable and are working to resolve the issue.