BreezeHost - BreezeHost Billing Portal Offline – Incident details

BreezeHost Billing Portal Offline

Resolved
Major outage
Started 4 months agoLasted about 1 hour

Affected

Websites

Major outage from 11:31 AM to 12:22 PM

Billing Panel (my.breezehost.io)

Major outage from 11:31 AM to 12:22 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    We have received reports that our billing portal is offline and we are currently investigating the issue. No other systems are affected. Updates will follow.